136

Lumia 920s suffering from brightness bug with Portico update? Here's a possible fix.

Although the majority of people who are on AT&T or Rogers who have upgraded their Lumia 920 to Windows Phone “Portico” are having no problems (in fact, quite the opposite), there is one bug that seems to affect a few people: auto-screen brightness.

As detailed in our Lumia 920 forums, the problem exhibits itself when you turn on the phone in a mildly lit room and the brightness seems to ramp up to max and then back down again, resulting in a staggered and constantly fluctuating display brightness.

As forum member iamtim wrote:

“Now I'm sitting in my chair - where the light is arguably not quite dim but not quite bright - and it's acting like it doesn't know what brightness setting it should be on. It doesn't go from dimmest to brightest, but it is kinda like... "ok, let's dim a little bit! no, wait, brighten up a tad! no, too bright, dim down some! Er, no, go bright!" It's not happening very rapidly, maybe about every 10 seconds or so it changes a bit.”

Many people have chimed in saying they are seeing the same behavior as well. For some, disabling “auto brightness” helped while for others this results in eve “low” being too bright:

“I keep my brightness set to low with auto off. Everytime I turn off my phone and turn it back on it jacks the brightness to bat signal bright even tho its set go low. To correct it I have to set it to high then back to low.”

Personally, we have not seen this on our four Lumia 920s here at Windows Phone Central—that’s not to say it doesn’t exist, just that this isn’t a universal problem that one will automatically get if they update. In that sense, it's more a quirky side effect than a reproducible bug.

Possible solution?

The issue appears to be one of calibration of the ambient light sensor—that is when the update occurred, the device may have calibrated in bright light (or perhaps it really just “screwed up”). That little sensor (found near the earpiece) is misjudging the light in the room and it’s causing wonky behavior, to say the least.

The good news is there may be a fix, which is seemingly simple:

  1. Take your phone into a pitch-black room
  2. Power on
  3. Slide your lock screen up
  4. ?
  5. Profit

Seriously, some people are reporting that is all it needs, which in a way makes sense. The phone needs to get a baseline reading of light including very low/no light. Without a bottom to go from, the phone can get muddled on the range it should use. Letting the phone be exposed to pitch black for a few moments may be enough to re-calibrate the system.

Now since none of our phones are exhibiting this phenomenon, we can’t verify if the above actually works (though it has been a go to in the past). For that, we turn to you folks to see if this accomplishes the task and alleviates the oddity. If so, sound off in comments and don’t forget to share your bugs and any issues in our support forum.

Could not connect