Xbox Live was having issues with purchasing content and launching games that are now fixed

Xbox One
Xbox One (Image credit: Windows Central)

What you need to know

  • Some users are having issues playing games on Xbox right now.
  • These users are getting an error message stating that "The person who bought this needs to sign in."
  • Other players are having problems buying things in the Xbox Store right now.

Update, Oct. 23 (4:48 p.m. ET): These issues appear to have been fixed.

We're seeing reports of players unable to access their games or purchase new content, getting an error message whenever they try to access their games that states "The person who bought this needs to sign in." Meanwhile, there's also been a small spike of reports on DownDetector, though it doesn't appear that this issue is affecting everyone.

Our Xbox editor Jez Corden is one of the people being affected by this problem and is getting the error message below.

Source: Windows Central (Image credit: Source: Windows Central)

Xbox Support confirmed these reports with an update on Twitter that the engineering team is looking into the problems. As of the time this article is being written, the Xbox Support website (opens in new tab) confirms the detected outage for purchasing content and accessing games.

See more

If you aren't having issues accessing your games, or you're currently getting the error message above, leave a comment below. We'll be sure to provide an update if the issues here get worse or are resolved.

Update, Oct. 23 (4:48 p.m. ET) — These problems are reportedly resolved

According to Xbox Support, these issues have been fixed.

Xbox Series X/S

Main

Samuel Tolbert is a freelance writer covering gaming news, previews, reviews, interviews and different aspects of the gaming industry, specifically focusing on Xbox and PC gaming on Windows Central. You can find him on Twitter @SamuelTolbert.

1 Comment
  • I couldn't play Forza Horizon 3/4 on PC just now, I got an error that I need to connect to the internet (my internet is running fine). I guess that's related to the Xbox server problem too.