We’re not sure what’s going on over at Google but either incompetence or the trolling bug has seized control of operations. Last week we saw a purposeful redirect of maps.google.com send Windows Phone users to the search page instead of allowing them to use Maps (Google later backed down) and now today it’s affecting YouTube.

The behavior is specific: head to m.youtube.com and click any video. In the past, such an action would launch Internet Explorer’s HTML5 video player, allowing Windows Phone users to watch just about everything that was mobile (assuming it wasn’t a Flash-only video). Now on Windows Phone 8 devices we get prompted to install an app.

While installing an app to watch a video may not seem like such a Herculean feat, we have to remember one thing here: we don’t have a YouTube app. Okay, technically we have the Microsoft YouTube player, which is just a front for the website, but the App prompt won’t actually reveal that. Instead, when a user clicks the “Search for app in the Store?” dialog box they are met with “Sorry, no apps found”.

Since as we mentioned the official Microsoft YouTube app is just a website wrapper, it exhibits the same behavior. The only opportunity users have would be to opt for a third party solution like Metrotube, SuperTube or PrimeTube. But when you search under ‘YouTube’ in the Store, those apps are slightly buried below some nonsense apps.

So what’s going on here (Windows Phone 8)?

As far as we can tell, the problem stems from Windows Phone 8 users using the default setting of Desktop Mode in Internet Explorer. Even though users can still navigate to m.youtube.com and view the mobile version of that site, videos simply will not play in that mode (on Windows Phone 7 devices where they don’t have the App Search ability, videos simply don’t play).

Switching to the Mobile view in Internet Explorer appears to alleviate the problem.

While that hardly seems like a terrible situation, it is causing confusion amongst users since the behavior has seemingly changed starting January 10th/11th for an unknown reason.


Reader complaints have started rolling in...

It gets worse for Windows Phone 7 users...

On Windows Phone 7 the problem is even worse as Desktop mode or Mobile version both don't work on m.youtube.com anymore at all. That differs from Windows Phone 8 devices where switching to Desktop Mode appears to "get around" the block.

One solution for some is to clear all of their Search History (cookies, passwords, websites) and restart the phone. Not an obvious solution but it seems to work.

Focus of continued problem

Google has famously stated that they have no plans to make official apps for Windows Phone and Microsoft has alleged twice that the company refuses to grant them meta-data access to allow them to make a high-quality YouTube app for their users.

Most Windows Phone users rely on Internet Explorer and HTML5 to view videos and although that still technically works, with Google disabling support for the desktop version it will cause usability problems. And Windows Phone 7 users are evidently just out of luck unless they clear all browser history and reboot their phones.

Much like the Google Maps issue, we’re not sure why Internet Explorer 10 on Windows Phone 8 would cause difficulties with YouTube. After all, the browser has the same rendering engine as the Windows 8 desktop version and is for all intents and purposes, the same browser. Like the Google Maps fiasco, Google must be targeting the “Windows Phone” string in the browser ID for whatever reason. When users switch to “Mobile view” this alters the browser string and since that has not been disabled by Google/YouTube, it works (at least for us).

Perhaps Google/YouTube are just making some backend changes or even more unlikely, Microsoft was granted permission to release an official app for YouTube (we’ll hold our breath). Either way, if you’re having problems viewing YouTube, let us know in comments including your OS and browser settings.